Sie sind nicht angemeldet.

bingo5

Wenigposter

Beiträge: 46

Registriert am: 30. Januar 2010

Danksagungen: 2

  • Nachricht senden

(permalink) 1

Dienstag, 18. Februar 2014, 18:20

Coolrunner lässt sich nicht Flashen (LPT)

Ich hoffe mir kann jemand helfen...

Also ich habe letztes Jahr April damit angefangen meine xBox360 Corona v3 zu modden. Damals habe ich die NAND ausglesen und ECC geflasht. Dann habe ich für meinen Coolrunner ein LPT Kabel gebastelt und fest gestellt dass mein PC kein LPT Port mehr hat... Dann habe ich erst einmal alles zur Seite gelegt.

Heute hat mich die Lust gepackt den Mod nun fertig zu machen. Ich habe hier einen alten Laptop mit LPT und dort den Coolrunner (auf PGR. eingestellt) angeschlossen. Eine kleine LED leuchtet dezent rot auf dem Coolrunner.
Dann habe ich mit J-Runner den flash versucht, dabei kam folgende Fehlermeldungen: "ERROR: TDO mismatch" und "ERROR at or near XSVF command #10. See line #10 in the XSVF ASCII file."
Habs dann noch mit dem 360gcprog versucht und dort kommt auch ein Fehler (weiß leider gerade nicht was drin stand... aber der Hinweiß ich soll mal meine Verkabelung überprüfen).

Also folgenden Chip habe ich: http://shop.konsolenchips.de/xecuter-coo…lone-p-904.html
Das Diagramm nach dem ich den LPT Programmer gebastelt habe: http://shop.konsolenchips.de/images/xbox…_programmer.jpg

So hat jemand ne Idee wo das Problem liegt oder was ich versuchen könnte? Ich habe gerade nochmal alle Leitungen durch geprüft - alles korrekt verlötet.

Danke schon mal!

Beiträge: 111

Danksagungen: 31

  • Nachricht senden

(permalink) 2

Dienstag, 18. Februar 2014, 18:43

Externe Spannungsversorgung (3,3V, z.B. 2 STück AA-Batterie) an den Chip (an VCC und GND). Laptop LPT Schnittstellen sind meist problematisch. Programmerkabel zum Chip so kurz wie möglich.

Im Bios auch mit den ECP/EPP Settings rumprobieren.

Alternatives Programmerschema:

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

bingo5 (18.02.2014)

bingo5

Wenigposter

Beiträge: 46

Registriert am: 30. Januar 2010

Danksagungen: 2

  • Nachricht senden

(permalink) 3

Dienstag, 18. Februar 2014, 20:44

Danke, werde ich morgen mal versuchen. Deine Schema wird mir übrigens nicht angezeigt.

Hmm mein Programmerkabel ist relativ lang.. so 50cm pro Kabel wirds schon sein.

edit://Das mit ECP/EPP (stand original auf "Normal") habe ich gerade versucht - bei EPP leuchtete die LED auf dem Coolrunner nicht und 360gcprog sagt "tdo seems to be stuck at 1", bei ECP leuchtet die LED und 360gcprog sagt dass wieder das mein Coolrunner nicht ordentlich mit Strom versorgt wird.
Ich versuchs dann morgen mal mit Batterien und wenn es nicht klappt, muss ich alle Kabeln kürzen... arg hätte ich das mal vorher gewusst... dachte halt, so länger um so freier kann ich löten ;)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »bingo5« (18. Februar 2014, 21:00)


Inpreator

ΩFreund

  • Bestätigter Glitcher

Beiträge: 234

Registriert am: 28. Juni 2013

Wohnort: Berlin

Xbox One: Standart Modell

Xbox360: Einige

Laufwerk: Alles da

Ich spiele z.Zt.: Nichts

Danksagungen: 58

  • Nachricht senden

(permalink) 4

Dienstag, 18. Februar 2014, 20:52

Das solltest du auf jeden Fall kürzen, Verkabelung ruhig mehrmals überprüfen, häufig sind trotz nachträglichem überprüfen noch Fehler drin, die man erst später sieht.

Gruß

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

bingo5 (18.02.2014)

knollo360

Wolfsrudel

Beiträge: 64

Registriert am: 15. April 2011

Xbox360: Slim4GB

Laufwerk: LiteOn 0225

Ich spiele z.Zt.: nichts

Danksagungen: 14

  • Nachricht senden

(permalink) 5

Dienstag, 18. Februar 2014, 21:44

Hatte das selbe Problem, habs dann nach dem Prinzip gebaut (siehe Anhang).
»knollo360« hat folgendes Bild angehängt:
  • Cheaptag — JTAG cable for CPLD-flashing.jpg

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

bingo5 (19.02.2014)

bingo5

Wenigposter

Beiträge: 46

Registriert am: 30. Januar 2010

Danksagungen: 2

  • Nachricht senden

(permalink) 6

Mittwoch, 19. Februar 2014, 01:04

Danke knollo360, mit deinem Schema hat es letztlich geklappt... habe auch die Kabel jeweils nur ~3cm lang gelassen... man war da eine fummellei.
Warum machen die CPLD Hersteller es einem so schwer? Für den JTAG meiner alten Xenon xBox habe ich nicht so lange gebraucht und war nicht so kompliziert (in Bezug auf die Stromversorgung) wie hier nur um dem CPLD zu flashen...

2 Fragen hätte ich noch:

1. GIbt es irgendwie nen Trick wie man ein Kabel an ne Batterie lötet? Also ich habe pro Pol bestimmt ne viertel Stunde gebraucht bis das Kabel halbwegs fest dran hing...
2. Kann ich die ganze Kabellage (ausgenommen der Batterie) beim Einbau dran lassen? Wenn die Timings nicht passen (habe 1-2 genommen), habe ich keine Lust noch mal alles zusammen zu löten... Mich graust es schon alleine davor, die Batterien wieder dran zulöten...

Und noch eine Frage zu nem anderen Thema. Beim JRunner werden mir beim Flashdialog für den Coolruner ja einige Optionen bezüglich der Timings angezeigt. Ich habe jetzt einfach 1-2 bei Corona genommen. Das ich RGX nicht nehmen soll weiß ich auch - aber jetzt die Frage: Was ist mit RGH2, soll ich diese Optionen
auch durch testen? (Wenn 1-2 nicht laufen sollte)

Staubsauger

̿̿ ̿ ̿’̿’̵͇̿̿з==(•̪●)==ε/̵͇̿̿/’̿’̿ ̿ ̿̿

  • Bestätigter Glitcher

Beiträge: 580

Registriert am: 24. Mai 2011

Xbox360: XBox 360 Trinity RGH(DualNAND)

Laufwerk: 16D4S

Firmware: Lt+3.0

Ich spiele z.Zt.: nichts

Danksagungen: 177

  • Nachricht senden

(permalink) 7

Mittwoch, 19. Februar 2014, 01:17

Warum machen die CPLD Hersteller es einem so schwer?


Naja, der RGH1 und RGH für Trinitys hatten jeweils nur ein Timingfile.
Was anderes gab es zu dieser Zeit nicht.
Zumal die neueren Glitchchips in der Regel schon vorprogrammiert sind. (R-Jtag, CR3Pro, X360Run usw.)

1. GIbt es irgendwie nen Trick wie man ein Kabel an ne Batterie lötet? Also ich habe pro Pol bestimmt ne viertel Stunde gebraucht bis das Kabel halbwegs fest dran hing...

Soweit ich weiß haben Batterien eine Beschichtung. Eventuell musst du diese abschmirgeln.

. Kann ich die ganze Kabellage (ausgenommen der Batterie) beim Einbau dran lassen?

Theoretisch schon. Kann allerdings sein, dass das deine Bootergebnisse beeinflusst.
Außerdem ist die Gefahr eines Kurzschlusses gegeben.

Frage: Was ist mit RGH2, soll ich diese Optionen
auch durch testen?


Jop

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

The Hidden (19.02.2014)

The Hidden

User mit Hirn

Beiträge: 296

Registriert am: 4. November 2012

Wohnort: Olpe

Ich spiele z.Zt.: mit meinem Lötkolben

Danksagungen: 103

  • Nachricht senden

(permalink) 8

Mittwoch, 19. Februar 2014, 09:30

habe auch die Kabel jeweils nur ~3cm lang gelassen... man war da eine fummellei.
Warum machen die CPLD Hersteller es einem so schwer?

Du kannst dir auch überlegen ob Du dir einen SPI Flasher a´la JR-Programmer oder ähnlich leisten willst. Der läuft über USB und braucht nur wenige sek. zum Schreiben der Datei für den CPLD.
Netter Nebeneffekt. Nicht so Fehler anfällig wie LPT und Du hast nicht so eine starke Limitierung der Kabel länge.
Signatur von »The Hidden« Marktplatz: The Hidden :D

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

Staubsauger (19.02.2014)

Beiträge: 111

Danksagungen: 31

  • Nachricht senden

(permalink) 9

Mittwoch, 19. Februar 2014, 09:41

Genau, ein JR Programmer macht die Sache deutlich einfacherer!

An Batterien zu löten ist keine gute Idee. Mit etwas Klebeband hält das auch oder ne Batteriehalterung besorgen.

NeXuLoUs

Hardwarehacker

Beiträge: 136

Registriert am: 24. Juni 2012

Xbox One: Day One, Elite

Xbox360: Xenon,Falcon v2, jasper, Trinity, Corona v2, v3 JTAG&RGH, DevKit

Laufwerk: LiteOn 74850c, 83850c, 94850c, 0225, 0272

Firmware: iXtreme LT+ 3.0

Rebooter/RGH: Xebuild-Freeboot

Ich spiele z.Zt.: Fallout4, Black Ops 3

Danksagungen: 32

  • Nachricht senden

(permalink) 10

Mittwoch, 19. Februar 2014, 11:32

Man Kann Auch über CK3 Pro mit strom 12V versorgen :)

The Hidden

User mit Hirn

Beiträge: 296

Registriert am: 4. November 2012

Wohnort: Olpe

Ich spiele z.Zt.: mit meinem Lötkolben

Danksagungen: 103

  • Nachricht senden

(permalink) 11

Mittwoch, 19. Februar 2014, 16:23

Hab auch noch nen DvD Probe der 3,3V raus wirft.
Who cares ;)

edit
Falls Du mit dem Rev D nicht zu Rande kommst, kann Ich dir nur nen X360Run empfehlen.
Macht Out of the Box schon meist gute bis sehr gute Glitch Zeiten (330mpf Kondi) vorraus gesetzt.
Und das schone ist, der ist schon preflashed. Konntest dir so die Kohle fur nen Programmer sparen. :fresse:
Signatur von »The Hidden« Marktplatz: The Hidden :D

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »The Hidden« (19. Februar 2014, 19:27)


Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

zoombi (19.03.2014)

Die hier veröffentlichten Texte stellen die Meinung des jeweiligen Autors dar. xboxhacks.de oder die Betreiber haften nicht! Weiterhin ist eine Nutzung dieser Texte ausschließlich
mit einer schriftlichen Genehmigung des jeweiligen Autors gestattet. Ist diese Genehmigung nicht erteilt, stellt dies einen Urheberrechtsverstoß dar, der u.U. rechtliche Folgen mit sich zieht!